Sites disappeared after update

Hey there,
I have just updated the system from 1.7 to 1.8.1. After the update all sites have disappeared from the Web interface. My L2-L4B products are luckily still listed.
Any ideas how to get the sites back in?

What I did so far:
-Reboot System
-systemctl restart sen2agri-services

sudo -u postgres psql sen2agri -c “select id, name from site;” shows me my sites correctly, but they are not accessible via the web interface.


We solved it.

Had to manually unzip der following file:


to the destination folder


Now it works.

I had the same situation this post helped.


Dear Oliver,

Thank you for your post. There was indeed a small issue in the update script. You did a great job by identifying the issue by yourself: the only missing step was indeed the one performing the unzip of the package.

Yesterday at 4PM the corrupted Sen2-Agri installtion package v1.8.1 have been replace by the correct one.

You can disregard this message if:

  • you downloaded the system later than Tuesday 8th at 4PM,
  • you installed the system v1.8.1 on a fresh machine (no Sen2Agri installed yet)
  • you performed the upgrade from the v1.8 to 1.8.1

If you performed the upgrade to the v1.8.1 from the v1.7 with the installation package downloaded earlier than Tuesday 8, 4PM, you could now face issues with your updated system due to the small error in the upgrade script (

However, that should be fixed very easily. You have two options to solve the problem:

  1. Download the new version again on the website (corrupted installation package have been replaced by the correct one) and run the script again (even if the system 1.8.1 is installed with the already downloaded package, it will not harm)
  2. Since the only missing step in the corrupted upgrade script from yesterday was the unpacking of the folder , you can also manually unpack this folder to the correct location runing the two following command (solution kindly proposed here above by Oliver). In this case, there is no need to download the new version again on the website.

mkdir -p /usr/share/sen2agri/sen2agri-services

unzip <path_to_sen2agri-service_zip_archive> -d /usr/share/sen2agri/sen2agri-services

We sincerely apologize for the inconvenience. We are making our best to provide you the best solution to generate relevant and performant agriculture products and we really thank you for your confidence!

Nicolas Bellemans for the Sen2-Agri team

Hi Nicolas,

I recenlty installed the 1.8.2 version on my CentOS7 (VirtualBox) and when I create new site the site never listed on the web GUI. I checked the /usr/share/sen2agri/sen2agri-services folder and the upzipped files are already there. Could you let me know what else I can do to get it running.

Thanks a lot,

I have the same issue

The sites are provided to the IHM by the sen2agri-services.
Could you please provide the following information:

  • the content of the “site” and “season” tables
  • check that the sen2agri-services are running ok (please provide a journalctl for the sen2agri-services).
  • Are any sites displayed in the IHM or an error message is displayed?
  • the content of the folders /usr/share/sen2agri/sen2agri-services/lib and /usr/share/sen2agri/sen2agri-services/modules
  • If you perform a “sudo systemctl restart sen2agri-services” do you get the sites displayed (after around 30 seconds after the execution of the command)?

I restart sen2agri-services. I can see the sites in the TAB sites, but not the new site I created in the TAB products (after restarting sen2agr-services). Downloads were made… However L2A were not produced. So I used command: “sudo systemctl restart sen2agri-demmaccs”. L2A were produced. After few hours of processing L2A apeares in the TAB products.
See journalctl for the sen2agri-services after restart:
log_services2.txt (427.9 KB)

Hi Pedro,
Apparently, for some reason your sen2agri-demmaccs daemon was stopped.
Nevertheless, please note that you should execute

sudo systemctl restart sen2agri-demmaccs.timer

Not only sudo systemctl restart sen2agri-demmaccs as this will only handle the L1C products present in the database at the moment of the execution and not the future ones.

Concerning the missing site, could you provide the content of the “site” and “season” tables, please?

Best regards,

Hi cudroiu,

I restarted sen2agri-services and refreshed the php site and I got this warning. Capture
If I refresh again this warning disappeared. However, everytime I create new site, it never shows on the site list although it prompted that I successfully upload the site.
Here is the journalctl result: journalctl.txt (5.6 KB)


Hello Jasmine,

The message "Cannot get site lists! Please check again … " is normal right after the restart of the sen2agri-services as it takes (as specified above) around 30 seconds to start (or more, depending on the configuration of the system and the load of te system). This is why, at a later refresh of the page, the message disappeared.
Unfortunately, the journalctl.txt file does contain only some initialization message. Doesn’t it contain several other messages after about 10-15 minutes?

Could you also provide the “site” and “season” tables content, please?
You can use the commands:

sudo -u postgres psql sen2agri -c “select * from site;” > sites.txt
sudo -u postgres psql sen2agri -c “select * from season;” > seasons.txt


Hello Jasmine,

Could you try the following command in the command line and then refresh the page:

sed -i -e “s|static \$REST_SERVICES_URL = \x27http://localhost:8080|static \$REST_SERVICES_URL = \x27http://localhost:8081|g” /var/www/html/ConfigParams.php

(You will have to pay attention to the quotes to write again the " as they should be updated when executing command if you make a copy/paste from here)

Hope this helps,

What’s the meaning of IHM?

Sorry, it should have been “HMI” - it is the web interface for accessing the system functionalities.