Cannot create new site Sen2Agri new installation v 2.0.2

Hello all,

I’ve installed the 2.02 version to a new CentOS machine. After chaging the ownership,
sudo chown -R apache: /mnt/upload , I’m still having errors uploading my site.

I’d made sure that my is valid. Any issues similar with me? I also uploaded my ls -ls command for /mnt/ folder. I think I have a lot missing files and directories in /mnt/archive compared to my previous installations of Sen2Agri.

Any suggestions, @cudroiu ?


In the root folder I created the symbolic link /mnt/ which points to actual storage which is /data/mnt/. There are other files and folders located in /data/. Is it possble that this condtion results to my issue? Below is the /data/ directory.


Hello Brent,

I tried simulating your situation but I did not succeeded and the site was successfully created.
My configuration that I created was like the following one that looked similar with yours so unless there are not other differences, there should be no problem:

Could you please check also the structure of your uploaded zip files? Maybe you have zipped the shapefiles containing also the directory that contained them.

Best regards,

Hello Cosmin,

I tried checking the .zip file of my ste using, no errors were found.
I also uploaded the .zip file into my old Sen2Agri installation and it uploaded successfully. Perhaps a clean install will address my issue. I’ll update you about it.


I have the same issues in safari, works in Chrome

Hello Cosmin,

Perhaps, there was trouble in the apache program settings because I have another program that uses it.


Hello Brent,

Could you please check with the script attached (1.7 KB) and tell me if there is any change?

Best regards,

Hello Cosmin,

Here is the result of my, in validating my shp file site to be uploaded.

Anyway, I temporarily uninstall Sen2Agri since there was another program installed that uses Apache, and we’re afraid it might cause some issues. I’ll update you about my progress in the coming days.

Thank you very much.

I am facing the same problem. Can you please explain how you manage to fixed this problem?

Could you please give more details on the error you have? Also, could you provide the shapefile that you use to validate it also on our side (if possible, of course)?
Is this a new installation that you have or an older one?
Is a restart of the httpd solving your issue? You can try something like:

sudo systemctl restart httpd

Can you check if you have any errors during the upload in the /var/log/httpd/error_log with?

sudo tail -f /var/log/httpd/error_log

Best regards,

The error Iam getting is as follows:“ Shape file has invalid geometry. Missing file due to a problem of selected file. I installed a new SEN 2 agric version

But from what I see in your message there is a difference compared with the original post of the thread. In your case it is said “Shapefile has invalid geometry”.
Could you check again your shapefile and correct it as it seems it is really invalid?
You could try to simplify it. Unfortunately, the system cannot do that for you and even if it would accept it, the SciHub would not return anything for queries having invalid polygons.


Thanks I managed to solve the problem

Could you also share, if possible, what was the issue and how you solved it (for any users encountering the same issue)?