Cannot create new site v3.2

Hello @cudroiu and @admins,

I am trying to create a new site after a fresh reinstallation of Sen2Agri 3.2.
I tried to follow all the suggestions in this post [actually this is my own post]
(Cannot create new site Sen2Agri new installation v 2.0.2)

I’ve tried everything from changing the ownership chown to apache and checking the validity of my shp file using the Here is the ls -ls result of my upload directory (I’m using a symbolic link, the original file is in /home/brentf/Documents/mnt/):

[brentf@ESSCGeo-Sen2Agri Agus_Pulangui]$ ls -ls /mnt/
total 8
4 drwxrwxrwx 6 sen2agri-service sen2agri-service 4096 Dec  8 19:39 archive
4 drwxrwxrwx 2 apache           apache           4096 Dec  8 18:12 upload

I’ve checked that my apache.service cannot be found.
Any workaround on this?


Hi Brent,

The issue might be the fact that your /mnt is a subdirectory of /home/brentf. Even if you gave full access to the directory /home/brentf/Documents/mnt the issue still remains for the parent directories.
As a first test to see that the rights are OK, you can try :

  • login under the user sen2agri-service:

    sudo su -l sen2agri-service

  • go to the /mnt/archive and /mnt/upload.
  • Check first that you can access these folders from the user sen2agri-service
  • Check that the user sen2agri-service has the write rights:

    touch test.txt

As it is not a good idea to give 777 rights on all above directories, I suggest you to move your mnt (not the symlink but the target directory that is now /home/brentf/Documents/mnt) to another location where you can give the proper rights and the user sen2agri-service and other users can write there.

Hope this helps.

Best regards,

Thanks Cosmin.

By the way, we’re still thinking of increasing our storage allocation to move the physical directory of ‘/mnt/’ directory via root path.