Installation MACCS failed

When I’m trying to install Maccs cots I have this issues :

Libxml2 is already the last version installed. If someone have an idea what is going wrong? Many thanks for your answer.

Are you on a 64-bit system?

What is the output of rpm -qa --qf "%{n}-%{arch}\n" | grep libxml2?

Yes it is a 64-bit system. When I try your command nothing in the output.

Looks like libxml2 is not installed, then. Try sudo yum install libxml2.

Hello, Thank you for you reply. An update of libxml2 solved this problem. But I did several step and I have a new message:

"[centos@localhost install_script]$ sudo ./
[sudo] Mot de passe de centos :
Checking paths…
Please unpack the SRTM dataset into /mnt/archive/srtm
Exiting now"
I don’t find the pack SRTM in the Sen2AgriDistribution directory?


It means that SRTM and SWBD zip files first are not included in the main Sen2Agri installation folder that you have right now. The said SRTM and SWBD have separate download links from Sen2AgriDistribution folder.

1 Like

Thanks for your reply.
Installation MACCS and Sen2agri works but after entering the default username and password sen2agri I have this message "Could not connect"
I try this solution but it doesn’t work:

I found the problem "Executing SQL script: ./database/07-data/13.user.sql
root n’apparaît pas dans le fichier sudoers. Cet événement sera signalé"
Everythings works now. Thanks!


That’s a good catch, I never saw sudo failing when running as root. But the sudo calls in the install script are unnecessary, so we’ll remove them.

I have the same problem, I have already updated the package but it is still reporting the error. Any ideas?