Couldn't insert the L2A products in web interface after MAJA processing

Hello,

I successfully enabled MAJA and got it going in this post. However, I am presented with this error after processing:

● sen2agri-demmaccs.service - Runs MACCS on L1C products
   Loaded: loaded (/usr/lib/systemd/system/sen2agri-demmaccs.service; static; vendor preset: disabled)
   Active: inactive (dead) since Thu 2019-05-23 12:44:46 PST; 45min ago
  Process: 31875 ExecStart=/usr/share/sen2agri/sen2agri-demmaccs/demmaccs_launcher.py (code=exited, status=0/SUCCESS)
 Main PID: 31875 (code=exited, status=0/SUCCESS)

May 23 12:44:44 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: 2019-05-23 12:44:44.861485:[31875]:dmworker_1: Rolling back for /mnt/archive/maccs_def/isabela19
/l2a/S2B_MSIL2A_20181010T021649_N0206_R003_T51QVV_20181010T074252.SAFE/
May 23 12:44:44 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: 2019-05-23 12:44:44.861581:[31875]:dmworker_1: Couldn't insert the product /mnt/archive/maccs_de
f/isabela19/l2a/S2B_MSIL2A_20181010T021649_N0206_R003_T51QVV_20181010T074252.SAFE/
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: Waiting for queue to join...
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: dmworker_0 will consume: None | l2a | /mnt/archive/maccs_def/{site}/l2a/
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: 2019-05-23 12:44:46.222470:[31875]:dmworker_0: No tile to process. Gracefully closing...
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: dmworker_1 will consume: None | l2a | /mnt/archive/maccs_def/{site}/l2a/
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: 2019-05-23 12:44:46.222532:[31875]:dmworker_1: No tile to process. Gracefully closing...
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: 2019-05-23 12:44:46.251921:[31875]:dmworker_1: Exit thread
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: All the workers finished their job. Exiting...
May 23 12:44:46 nirvana-ESSC_MNL demmaccs_launcher.py[31875]: 2019-05-23 12:44:46.251966:[31875]:dmworker_0: Exit thread

I deleted another site (and its downloaded images and L2A products from the database) which had the same geographic coverage as the site running with maja.

Does this problem has something to do with the database? I’m thinking to have a clean install/uninstall as other problems also emerged like this.

Any ideas, @cudroiu?

Regards to all,
Brent

I’m having similar warnings, after installing 2.0, and starting a new site…
Download is ok, but no L2A is not generated.
log.txt (1.6 KB)

Hi Pedro,

You can visit this post. I also encountered that issue in your log. Hope that it will help.

Regards.

Hello,

I have created a new patch for the systems that were initially installed with version older than 1.8.3.
This patch can be downloaded from here patch_1_upgrade_183_20.zip (3.3 KB)
(it will be soon publicly made on the download page of the system).

Please let me know if this solves your issue.

Best regards,
Cosmin

Thanks! I runned the patch.
MAJA did not run successfully.
attached the log file.
demmaccs_29SND.log (15.9 KB)
Pedro

Hello,

Have you also used the gipp for MAJA? From the logs I noticed that you are using the gipp in the folder /mnt/archive/gipp but I am not sure if there are the GIPP form MAJA or for MACCS.
If the gipp were not updated, you can:

  1. Use the script update_gipp.sh from the installation package
  2. Use the following procedure:
    • copy from the installation package the gipp_maja folder to /mnt/archive (such that the gipps are in /mnt/archive/gipp_maja)
    • update the database to use the new folder:
 sudo -u postgres psql sen2agri -c "update config set value = '/mnt/archive/gipp_maja/' where key = 'demmaccs.gips-path'" 

Cosmin

We were using an updated gipp for MAJA . We just maintained the folder name equal. But to make sure we are not missing we changed according with your instructions.
The log result was similar: demmaccs_29SND.log (37.6 KB)
Pedro

Hello Pedro,

From what I see in the logs, MAJA is trying to search some XML node in a file from gipp and cannot find it. If you are using an updated gipp, are you sure you are using a version that is compatible with the MAJA version that you use.
Unfortunately, MAJA is not under our development and we cannot come with a solution for this as it is a third party tool that we use. Maybe you can redirect the question to the CNES development team that are the ones that are the authors of MAJA (Olivier Hagolle maybe can help you with this).

Best regards,
Cosmin

we installed the latest version of Maja (i.e., 3.3.0…) sorry for that…
we are going to install Maja 3.2.2.

Hello Cosmin,

I applied the patch and the MAJA processed L2A images are now in the database.
I’ll just be waiting for the update for the sen2agri-services since my site is located near the equator.

Brent

we manage to run the maja, and see all the tiff files with bands mask, etc (THEIA stile). but L2A products do not show on web interface. In database the L2A Deoes not show anywhere as processed ( tables: l1_tile_history, dwnload_history) Could this warning be in any way related:

  • start.sh[25860]: 2019-May-27 19:40:13.699 WARN [thread_pool_executor-2] o.s.o.j.v.HibernateJpaDialect - JDBC Connection to reset not identical to originally prepared Connection - please make sure to use connection release mode ON_CLOSE (the default) and to run against Hibernate 4.2+ (or switch HibernateJpaDialect’s prepareConnection flag to false
    Thanks
    Pedro

Hi Pedro,

Perhaps you’re having a similar situation as mine. Are your site located near the equator? The Sen2Agri team is currently doing an update for sen2agri-services. Also please take note that successfully processed images that fall within three months before your time coverage are not shown in the web interface. It only appears on the sen2agri database.

Regards.

Area is in Portugal, very far away from equator.
We have no problem in the download, that I’m aware . Moreover because Maja runs, but it does not write in to the data base.
Pedro

Hi Pedro,

Have you successfully inserted the L2A products into your database?

Brent

No.
We do not find any clear error that could be in the orgin of this except for what I mentioned in my post of 23 of May.
BR
Pedro

Hello,

We have corrected the issue with the download of products from sites defined near equator or GMT and also the USGS download issue but it seems that the release of a new updated system (2.0.1) is a little bit delayed. Meanwhile, you can use the archive from here to update your system:


You should copy only the content of lib/ and modules/ in the corresponding folders from /usr/share/sen2agri/sen2agri-services.
Also, for MAJA, you should consider also the updates described here:

Concerning the products in the database, could you check directly via a select in the table “product” if there are any products there? When you create a new site, the system is downloading and processing L2As 3 months before the start of the season but these products are not visible in the web site.

Best regards,
Cosmin

Short answer because I’m traveling:
Table products only has informartion on the sites created previous to update of the sen2agri 2.0.
However, note that the “3 months before the start” tiles were downloaded
BR
Pedro

Dear Cosmin,
We still did not get the new version to work.
demmaccs_launcher is returning the following log log.txt (1.1 KB)
As I said in my previous post, we know that the demmaccs/maja works because we manage to run it manualy.
We also know that the archive folder has complete privilege of read and write (777), so we do not understand the error log.
Finally we installed the latest version of Sen2Agr (Version 2.0.1 [Release 10-07-2019])i from scratch on a new linux machine, and the error log was the same.
Any ideas?
BR
Pedro