Start visualization tool

Dear sen2agri community,

we tried to run the visualization tool in docker container following the officual v3.0 manual. The container was successfully imported, but we are not able to start it. The command docker run --name "sen2agri2geoserver" -tid -p 8080:8080 -v /mnt/archive/:/s2agri_products sen2agri2geoserver /sen2agri2geoserver/script/ always returned the error message: `docker: Error response from daemon: error while creating mount source path ‘/mnt/archive’: mkdir /mnt/archive: file exists.

We also tried the following .yaml script:

version: "3.0"
     user: 602046:5200
     image: sen2agri2geoserver:latest
        - "8081:8080"
        - /mnt/archive:/s2agri_products
        - /Sen2Agri2Geoserver/script/

How can we solve this issue? Thanks in advance!

Issue solved. We checked the user permissions to the folders and our nfs mount needed some particular attention.


Could you please help me in setting up the visualisation tool?

So far, I have:

  • installed docker-ce
  • I have the sen2agri2geoserver.tar file locally
  • I run the docker run --name “sen2agri2geoserver” -tid -p 8080:8080 -v /mnt/archive/:/s2agri_products sen2agri2geoserver /sen2agri2geoserver/script/ command

and I getUnable to find image ‘sen2agri2geoserver:latest’ locally

Can you help?

Thanks in advance


have you imported the dockerfile? This needs to be done first by docker import <path>/sen2agri2geoserver.tar sen2agri2geoserver:latest
Then you can try the docker run or write an *.yaml to start the container
version: "3.7" services: sen2agri2geoserver: image: sen2agri2geoserver:latest ports: - "8081:8080" entrypoint: - /Sen2Agri2Geoserver/script/