Sites created but the system is not downloading the data

I created two sites and set define the seasons, but when I check on the system to the monitoring system to view the progress , It shows that the system is not downloading . It’s now a day after I created and set up the sites, there is nothing on the progress section

You can view the photo , of what Iam getting

Check if the sites were enables correctly (there are 2 switches).
Are the login parameters for esa/USGS correctly set? If you have just created an account at ESA it takes some time until you can use the api.

I created the two sites sometime last year in November and set the season from October 2020 to the end of May 2021. I have been monitoring the sites for downloading progress. On download statistics, The system gives me different numbers of files to download every time I check. However on current downloads, it’s showing no progress. Products sections there is nothing as well. Kindly refer to the image above, How can I resolve this problem. I should be starting to see products now and the downloaded files.

On the product section here is my query refer to the image below

The image below shows the results :

My query resulted in no data displayed. I am not sure whats transpiring if the system is not downloading. Is it possible that there is somewhere in the system that need to be set properly. How can I resolve this problem. Where should I start to look at. I would appreciate your feed back on this challenge

I have checked the login parameters for ESA/USGS are correctly set. On downloading statistics it’s showing the total number of files successful downloaded. On the tab below for current downloads it’s not showing the progress. The other issue there are no current products or files that have been downloaded. Kindly refer to the images below

Dear Adolph,

From one of the previous captures, it seems that your system successfully downloaded 851 products.
The reason why you don’t have products in the “Products” tab is that your L2A pre-processor does not works correctly (maybe MAJA not correctly installed or configured).
Could you please provide me the following information?

  • logs for the sen2agri-demmaccs

sudo journalctl -fu sen2agri-demmaccs --since “30 days ago” > logs_demmaccs.txt

  • content of your config table:

sudo psql -U admin sen2agri -c “select key, site_id, value from config” > config_table.txt

  • could you try the following command also and let me know the result:

ls -l /opt/maja/3.2.2/bin

  • Also, the result of the following command:

ls -l /mnt/archive

Please send me the files logs_demmaccs.txt and config_table.txt along with the results for the rest of the commands.

Best regards,

Dear Adolph,

It seems that you installed MACCS instead of MAJA in your system.
MACCS is deprecated and is not maintained anymore by CNES and it also has some issues with the S2 products.
Please go to:

And make sure that you will download MAJA Version: 3.2.2 [TM].
Please make sure this is the version that you download and install.
Once you did that, perform the following operations:

  • install MAJA version 3.2.2 (normally, you should execute the binary

sudo ./

  • Ensure that everyone has the rights to access the new MAJA installation:

sudo chmod -R a+rx /opt/maja

  • Configure the system to use the new installed MAJA instead of MACCS:

psql -U admin sen2agri -c "update config set value = ‘/opt/maja/3.2.2/bin/maja’ where key = ‘demmaccs.maccs-launcher’ "

  • Reset the statuses of the failed products tried to be created with MACCS:

psql -U admin sen2agri -c “delete from l1_tile_history”
psql -U admin sen2agri -c “update downloader_history set status_id = 2 where status_id in (6,7)”

  • Once you do that, please log for 2-3 hours the messages for the demmaccs :

sudo journalctl -fu sen2agri-demmaccs > logs_demmaccs.txt

To be sure you correctly performed all above operations, please send me again:

  • the logs_demmaccs.txt file
  • config_table.txt file after running the command

sudo psql -U admin sen2agri -c “select key, site_id, value from config” > config_table.txt

  • the result for (but please execute the command exactly like this, no cd or other operations before):

ls -l /opt/maja/3.2.2/bin

Please let me know.

Best regards,

Dear Adolph,

According to the files you sent, it seems that the problem was solved (the system seems that succesfuly processed the first L2A products).
Do not panic if you do not see them yet in the web interface as the system is processing 2 months before your season (for MAJA training) and the products in this interval are not visible in the “Products” tab.
You will see the products in the web interface once the processing starts to take place inside the season.

Please let me know if you encounter any other issues.

Best regards,

Noted, thank you very much. I will advise if I encounter any problems