Problems after fresh install 1.8.2

I fresh installed 1.8.2 version of Sen2Agri and realized following problems:

  1. When I configured two sites, the system is downloading only Landsat data no Sentinel 2 data. ( is from my point of view well configured and the changes are imported in datasource table in database) (see attached files)
  2. The sites are visible under Sites in web interface. The Landsat downloaded data are processed by MACCS and stored in /mnt/archive/maccs_def/site_name_l2a folder. They are marked in downloader_history (see attachment) as processed and stored in product table (see attachment), but only small part of them is visible in Products in web interface. (see attached screenshot)
    Could you pls help me what is wrong. 1.7 version was working by me without problems.

Kind regards
Jan Semrad (2.0 KB)
datasource.csv.txt (1.8 KB)
downloader_history.csv.txt (5.9 KB)
product.csv.txt (12.7 KB)

For the first point, could you provide the logs for the sen2agri-services, please?
For the second point, it is normal in this version to not display anymore all the products. The reason why you find more L2A products in the “product” than in the IHM is the following:

  • I assume you defined a season starting from May
  • The system is actually downloading and processing L1C to L2A products starting from the start of the season minus 3 months. This is done in order to initialize MACCS for the nominal mode and to have better quality for products at the beginning of the season (MACCS is using the previous L2A product for improve the quality of the currently product). The products between Tseason_start - 3 months and the Tseason_start are not thus considered in the processing and they should not be also displayed (this was introduced in 1.8) as they are outside of season and of potentially poor quality. This is why you don’t have in the IHM displayed the products from February to May.

Thank you for answer.
For the 1st point - See attached log for Sen2agri services (for last two days) (2.5 MB)
For the 2nd point Regarding products in IHM now I understand and it´s solved for me.

Best regards


Could you send me the content of your “site” table, please?

sudo -u postgres psql sen2agri -c “select * from site;” > sites.txt

And send me the file sites.txt, please.

I have some problems to get it over terminal access by sudo. But I get it throug pgAdmin as CSV file. See (5.2 KB)

After analyzing the site extents, these are not valid for the application as they are looking as below.
The application does not supports self intersecting polygons.
Could you correct the site extent shapefiles and try creating again the sites?


Hi, I changed the shape file to very very simple polygon (see attachement). Created new site, but still no success - Landsat is downloading, Sentinel2 no. In attachement see the shape file a site table in (5.4 KB) (1.5 KB)

Hello, I still don´t have feedback from you regarding this issue. Is there anything new?

Thank you, rgds


Hi Jan,
Please have a look at this post: Amazon Web Service change for Sentinel-2 access. The problem you encountered right now is certainly linked to that issue. We are working on it currently and should provide an updated version in the coming days.


Thank you for clarification, sorry I did not catch this new topic in the forum.

I will wait for update.