No Products after Dowloads


#1

Hi all,

finally here I am.

I managed to install Sen2Agri, to create a site and to download .SAFE. But in the end I do not get any Products.
Unfortunately, I’m not very practical with Linux. I tried to solve by reading in other threads, but I failed.

Please help me!

Thanks in advance for any help you can give me.

Riccardo


#2

Then, I deleted and installed everything again on a second pc. Images download starts, but stops due to insufficient disk space. (10 TB are REALLY necessary or “recommended”?)
We wanted to test the SW, but for now it would be enough to test the atmospheric correction tool.
Is it possible to use MACCS independently from Sen2Agri?
Is there a standalone version?

Thanks


#3

Hi all,
with a bit of effort I managed to install everything correctly and start the downloads, BUT … I ran out of disk space!
Can you help me to change the path of the /mnt/… folder to move it to another partition?
Pleeease!!


#4

Hi,

You should move everything to your larger disk/partition. You can do so by doing a symbolic link between the current location of your archive directory and your larger disk. Follow these steps:

Before doing that you should stop your sen2agri system like this and restart it after symlinks re created.

# Move the current archive directory that contain all the files downloaded and prodeuced by the Sen2-Agri system
sudo mv /mnt/archive/ /path/on/largerdisk/
# Be sure that all users still have rwx access rights
sudo chmod -R 777 /path/on/largerdisk/archive
# Create a symbolic link between your /mnt/ diretory and the new location of the archive directory `ln -s destination origin`
ln -s /path/on/largerdisk/archive/ /mnt/

Hope this works for you
Nicolas


#5

Hi Nicolas,

Thanks for the reply!
I’ll try this way and I will update you on progress.
Thank you again.

Riccardo


#6

My steps was:

  • create a site
  • define the season
    -> images downloads starts
  • disable the site
  • stop the “services”
  • move the /archive/ folder and created the link
    but once the services are restarted, the downloads don’t start again (but the “Failed downloads” counter increases).
    I don’t konw what to do…

#7

I try also to modify some path with Sen2Agri-Configurator, but nothing…


#8

Hi, can you try looking at the output of journalctl -u sen2agri-services? It might indicate why the downloads are failing.


#9

Sure, the output is this…

output.txt (2.2 MB)

output2.txt (412.0 KB)


#10

ago 03 15:45:00 hpdl360gen9 start.sh[22183]: java.lang.NumberFormatException: For input string: “0,0000”

That looks like a locale issue (decimal point vs. comma). Your system might be configured with a non-C locale. The logs are not too helpful, but one place that the 0,0000 value might come from is the database. To check, please run something like sudo -u postgres psql sen2agri -c "select 3 :: float / 2".


#11

The command give me this message:

"could not change directory to “/home/riccardo”: Permesso negato
?column?

  1.5

(1 row)
"
but I don’t know if it’s useful…


#12

It’s 1.5, and not 1,5 as I expected. What do you get for the following?

sudo su -l sen2agri-service
localectl
env

#13

[sen2agri-service@hpdl360gen9 ~]$ locatectl
bash: locatectl: comando non trovato…
[sen2agri-service@hpdl360gen9 ~]$ env
XDG_VTNR=1
XDG_SESSION_ID=1
HOSTNAME=hpdl360gen9
SHELL=/bin/bash
TERM=xterm-256color
HISTSIZE=1000
QT_GRAPHICSSYSTEM_CHECKED=1
USER=sen2agri-service
LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=05;48;5;232;38;5;15:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:st=48;5;21;38;5;15:ex=38;5;34:.tar=38;5;9:.tgz=38;5;9:.arc=38;5;9:.arj=38;5;9:.taz=38;5;9:.lha=38;5;9:.lz4=38;5;9:.lzh=38;5;9:.lzma=38;5;9:.tlz=38;5;9:.txz=38;5;9:.tzo=38;5;9:.t7z=38;5;9:.zip=38;5;9:.z=38;5;9:.Z=38;5;9:.dz=38;5;9:.gz=38;5;9:.lrz=38;5;9:.lz=38;5;9:.lzo=38;5;9:.xz=38;5;9:.bz2=38;5;9:.bz=38;5;9:.tbz=38;5;9:.tbz2=38;5;9:.tz=38;5;9:.deb=38;5;9:.rpm=38;5;9:.jar=38;5;9:.war=38;5;9:.ear=38;5;9:.sar=38;5;9:.rar=38;5;9:.alz=38;5;9:.ace=38;5;9:.zoo=38;5;9:.cpio=38;5;9:.7z=38;5;9:.rz=38;5;9:.cab=38;5;9:.jpg=38;5;13:.jpeg=38;5;13:.gif=38;5;13:.bmp=38;5;13:.pbm=38;5;13:.pgm=38;5;13:.ppm=38;5;13:.tga=38;5;13:.xbm=38;5;13:.xpm=38;5;13:.tif=38;5;13:.tiff=38;5;13:.png=38;5;13:.svg=38;5;13:.svgz=38;5;13:.mng=38;5;13:.pcx=38;5;13:.mov=38;5;13:.mpg=38;5;13:.mpeg=38;5;13:.m2v=38;5;13:.mkv=38;5;13:.webm=38;5;13:.ogm=38;5;13:.mp4=38;5;13:.m4v=38;5;13:.mp4v=38;5;13:.vob=38;5;13:.qt=38;5;13:.nuv=38;5;13:.wmv=38;5;13:.asf=38;5;13:.rm=38;5;13:.rmvb=38;5;13:.flc=38;5;13:.avi=38;5;13:.fli=38;5;13:.flv=38;5;13:.gl=38;5;13:.dl=38;5;13:.xcf=38;5;13:.xwd=38;5;13:.yuv=38;5;13:.cgm=38;5;13:.emf=38;5;13:.axv=38;5;13:.anx=38;5;13:.ogv=38;5;13:.ogx=38;5;13:.aac=38;5;45:.au=38;5;45:.flac=38;5;45:.mid=38;5;45:.midi=38;5;45:.mka=38;5;45:.mp3=38;5;45:.mpc=38;5;45:.ogg=38;5;45:.ra=38;5;45:.wav=38;5;45:.axa=38;5;45:.oga=38;5;45:.spx=38;5;45:*.xspf=38;5;45:
MAIL=/var/spool/mail/sen2agri-service
PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/sen2agri-service/.local/bin:/home/sen2agri-service/bin
PWD=/home/sen2agri-service
LANG=it_IT.UTF-8
HISTCONTROL=ignoredups
SHLVL=1
XDG_SEAT=seat0
HOME=/home/sen2agri-service
LOGNAME=sen2agri-service
XDG_DATA_DIRS=/home/sen2agri-service/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/
LESSOPEN=||/usr/bin/lesspipe.sh %s
_=/bin/env


#14

Can you try to change /etc/locale.conf to LANG=en_US.UTF-8 or something similar, then restart the system?

Alternatively, you can change the setting for that service only, but it might not be enough. To do that, run sudo systemctl edit sen2agri-services, and add the following:

[Service]
Environment=LANG=en_US.UTF-8

After saving the file, run sudo systemctl daemon-reload and sudo systemctl restart sen2agri-services.


#15

I did it, but it seems not to have worked…the downloads have not restarted.


#16

Which solution did you pick, and can you confirm that the LANG is now different?


#17

I changed directly /etc/locale.conf and now I have LANG=en_US.UTF-8.


#18

Did you restart the system? Does journalctl report the same errors like before?