L4A Crop Mask fails


#1

Dear all,
I have been trying to process a L4A crop mask. After 2 days of processing the thing crashes and gives me the following error output:

"…Traceback (most recent call last):
File “/usr/lib/python2.7/site-packages/sen2agri_common.py”, line 618, in execute
self.validate(context)
File “/usr/bin/CropMaskFused.py”, line 702, in validate
run_step(Step(“ProductFormatter”, step_args))
File “/usr/lib/python2.7/site-packages/sen2agri_common.py”, line 129, in run_step
executeStep(step.name, *step.arguments, retry=step.retry)
File “/usr/lib/python2.7/site-packages/sen2agri_common.py”, line 74, in executeStep
raise Exception(“Error running " + name, result)
Exception: (‘Error running ProductFormatter’, 1)”

Any ideas?

Oliver


#2

The step_resource_log for the relevant taks gives me the following information.

> itk::ERROR: ProductFormatter(0x21cacf0): Fail to create destination root directory /mnt/archive/bfn_mm_2016/l4a/

I have done chmod 777 -R on the sen2agri folder, but this did not change anything

Anyone had a similar issue?

Regards
Oliver


#3

I solved it. It was a ownership problem. Resetting the folder owner with chwon to sen2agri-service solved this issue