Insert_l2a_product_to_db.py does not import data (V2)

Hi,

I am trying to insert l2a data into my site (sen2agri v2.0) with insert_l2a_product_to_db.py.

I run the following command:

python /bin/insert_l2a_product_to_db.py -s testsite -p l2a -t l2a -d /mnt/archive/BA_L2A/l2a/S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE

Which prints the following messages:

Inserting single product: /mnt/archive/BA_L2A/l2a/S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE/
Output path: /mnt/archive/BA_L2A/l2a/S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE/
Product dir is: S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE
2019-07-02 07:32:17.931413:Creating common footprint for tiles: DBL.DIR List: []
Product name is: S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE
OrbitId is: <_sre.SRE_Match object at 0x7f21b4a14c60>
2019-07-02 07:32:17.935607:Processed tiles: []  to path: /mnt/archive/BA_L2A/l2a/S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE/
2019-07-02 07:32:17.938505:Only set the state as processed in product (no l2a tiles found after maccs) for product /mnt/archive/BA_L2A/l2a/S2A_MSIL2A_20150918T103036_N0204_R108_T30PUT_20150918T104421.SAFE/a

However, nothing is imported, and there is no entries in the product table.

Am I doing anything wrong?

Hello,
The script for importing the products was not updated in version 2.0 to deal with MAJA products (I assume you have tried on these products).
This script was updated in version 2.0.1 and will be delivered in the next days. The version of the script that will be included in 2.0.1 is here (please change the extension to .py and make sure the line endings are in Linux format):
insert_l2a_product_to_db.txt (21.8 KB)

Best regards,
Cosmin

1 Like