How to diagnose downloading issues? (sen2agri 2.0)

Hi everyone again. After installing the system with automatic setup and uploading 2 sites (1 season each, one past and one realtime) I’m still experiencing the “download don’t start” problem.

After searching the forum for solutions and trying different approaches i’m still stuck in this phase.
My situation is the following:

WebGui:
System Overview shows Disk 0/0 (is that normal? this really makes me worry about bad sys setup)

postgres:
downloader_history => always empty

dashboard:
task are created for the sites

journalctl:
sen2agri-orchestrator[4004]: Unable to process event id 4: No products provided at input or no products available in the specified interval

datasources enabled only :

  • sentinel2 scientific data hub
  • landsat8 USGS
  • there is also a third record in the DB (guess sentinel 1) enabled, it doesen’t show on the web interface but is enabled and refers to satellite_id:3 with specific_params dsParameter":[{“name”:“platformName”,“type”:“java.lang.String”,“value”:“Sentinel-1”},{“name”:“productType”,“type”:“java.lang.String”,“value”:“SLC”

download paths are
/mnt/archive/dwn_def/s2/default
/mnt/archive/dwn_def/l8/default

they are defined by installation but dont get created… i guess writing permissions on archive and upload are ok…

Any idea where to start looking?

Thanks to all!

Hello,

Is this a new installation or an update from an older version?
You can try the following:

  • go into /usr/share/sen2agri/sen2agri-services/config/
  • edit the file application.properties in order to set the value “TRACE” (it is info in this moment) for the following keys: “logging.level.org.esa.sen2agri” and “logging.level.ro.cs.tao”.
  • log the journalctl messages from sen2agri-service
  • restart sen2agri-services and wait several minutes - 20-30 minutes

Please provide us the logs you saved.

Best regards,
Cosmin

Hi cudroiu thank you for the reply!
It’s a second install on the same system. First I tried with 1. 8.3 but withdout luck… then unistalled the whole system end performed a second install with 2.0 but I’m experiencing the same identical problem.

I followed your instructions and started to look into the log. I’m seeing already that the system complains about sentinel 1. I’m really in the hope to finally solve!

out.txt (134.7 KB)

Hello,

Could you please provide some information about the sites that you created? Are the seasons for those sites enabled and the sites themselves also enabled?

sudo -u postgres psql sen2agri -c “select * from site”;
sudo -u postgres psql sen2agri -c “select * from season”;
sudo -u postgres psql sen2agri -c “select * from datasource”;
The S1 messages are not blocking ones, just informing that is disabled (and this is normal).

Best regards,
Cosmin

Hi Cosmin, here the database records, exported them as csv. I replaced valid datasource credentials with “XXXXXX”. they sould be fine since I used them for login on scientific hub and USGS

season.txt (94 Bytes)
site.txt (231 Bytes)
datasource.txt (1.6 KB)

Thank you for your support and regards!

Hello,

Could you check in the “Datasource” tab from the system web interface if for SciHub and USGS you have the “Scope” set to “Query and download”, please?
From the “datasource.txt” file it results that this is set only for query.
Also, please make sure the Amazon data sources (for both S2 and L8) are disabled.
I tried your site and seasons on one of our machine and there is no issue here (the downloads started with no problem) so the problem might be a wrong configuration of the datasources.
Once you do this, you could try also restarting the sen2agri-services.

Hope this helps,
Cosmin