Files missing from /usr/share/sen2agri

I just installed Sen2Agri v1.8.1 on a fresh CentOS 7 machine. During the installation everything looked fine but afterwards when I run sen2agri-config it indicates that some files are missing from the /usr/share/sen2agri/ directory. The missing files have .txt, .map, .lut and .cfg endings and are requested by the processors. As an example I am attaching a screenshot from the L3A processor tab but L3B, L4A and L4B are also affected.

Are those files no longer needed and the paths can be set to empty string, or are they missing from the installer?


Hi Rado,

This is very strange. I just tried installing a fresh copy of the system on a machine and I did not get these errors.
Can you try execute:

sudo yum -y remove sen2agri-processors ; sudo yum -y install sen2agri-processors-1.8.1.centos7.x86_64.rpm

After that, try start again the sen2agri-config application.

Best regards,

Hi Cosimin,

Thanks for the tips! sen2agri-processors was not installed. When running the install command I get a dependency error from gdal coming from pgdg94 repository (see the screenshot). does not exist in /usr/lib64 but and are there. Should a create a symbolic link to from one of those files, similarly to what you do with in the installation script?



It looks like a version conflict on libgeotiff or some other package that requires. I tried running the installer in a centos:7 Docker container and it resulted in:

# rpm -qa | grep gdal

# rpm -qa | grep geotiff

# rpm -ql libgeotiff

You probably have an older version of libgeotiff. What do you get for the commands above, and what happens if you try to run yum update libgeotiff, or to remove and reinstall it?

I think we encountered a similar issue in the past and ended up installing that package manually, from

The image which I used (which I though was clean) actually had a lot of GIS software included and that caused the conflict. I removed liblas, installed libgeotiff-1.4.0 from your link and run and now sen2agri-config does not report missing file errors.
Thanks for the help!


Ah, okay. I think the past issue I mentioned is one that you’ve encountered. So this explains it.