Automatic download of images doesn't start


I have just installed the version2.0. I did set-up a new site. But the automatic download isn’t starting. I checked the mnt/archive/dwn_def folder. I can find different folders under s2 but no images as well as no L8 folder. The corresponding images and system status has been attached for reference.
Can anyone suggest what might be the issue.?

Did you check that you have permission rights to mnt folder?

It seems that the sen2agri-services.service is encountering some error in downloading.


I did follow the manual for setting the permission. I think sen2agri-service has the permissions(Image). Btw if everything works normally, how long does it take to start the automatic download process…? I mean should I leave it running for one day and see. Because last time I waited for 2 hours it didn’t download.

Maybe you can consult Cosmin(@cudroiu) or Laurentiu(@lnicola) both of CS Romania, as they are the ones involved in updating the sen2agri-services processor. Sorry, my knowledge in debugging the error is quite limited as of now.



The version 2.0.1 is available on the sen2agri official site. Normally, the upgrade to this version should solve the issue of L8 cloudCover new introduced field. Unfortunately, from the logs I couldn’t deduce why S2 is not working. Please let us know if the issue still remains with version 2.0.1.

Best regards,

Hello @cudroiu ,

I did change the settings in the database manually. I guess the changes I made under usr/share/sen2agri/sen2agri-services/config/ were not being reflected in the database. I installed Pg Admin 3 and modified the “datasource” table manually. In my case by default the scope of AWS (S2 and L8) scope was 2 as well as for SciHub and USGS scope was 1. So I set the scope as 1 for AWS (for S2 and L8) also disabled it and set the Scope for SciHub and USGS as 3. (Images below)

As a result the S2 data were downloaded but L8 data are still not being downloaded which might be the problem with cloud cover. So as you mentioned I will update the Sen2Agri to version 2.0.1 and confirm if the problem persists.

Scope Values

Enabled or Disabled values

The AWS is not supported anymore from the remote access but is still present into Sen2Agri for users who want to install the system directly on a paid AWS machine and use the data from their buckets. For now, remote access to AWS (even paid access) is not supported in Sen2Agri.
But, in any case, the page “Datasources” from the system web interface can be used to configure the datasources (without the need of using pgadmin3).
Waiting for your feedback for the update for 2.0.1. :slight_smile:

Best regards,

Although my download has completed but the L2A processor isn’t working. I find blank folder under demmacs_temp. So I did try to run the code manually as well as using SNAP. But I get exception error as invalid syntax in both the case (images attached).

Result from manual code

Result from SNAP

I found out two log files under /mnt/archive/maccs_def/l2a/S2A…/. It shows the the scrip failed. The reson for failure is written has none. So I’m unable to figure out what might be the issue.

Could you try the same command under the sen2agri-service user, please?
The idea is to have write rights on all the folders where demmaccs is writing (demmaccs_tmp and maccs_def.
Also, please make sure that before to run:

sudo chmod -R a+rx /opt/maja

I have already given write access to /opt/maja. But when I am trying to change the user by “su sen2agri-service” it is asking for password. I did type the password as “sen2agri”. But I get authentication failure. So I wonder what is the password.

So I did execute “sudo su -l sen2agri-services”. Then I did run the The logs of the command has been attached below.
sen2agri_demmacs_log.txt (15.4 KB)

If you want to run manually the demmaccs script, you will have also to :

  1. Either stop the sen2agri-demmaccs service and timer:

sudo systemctl stop sen2agri-demmaccs.timer sen2agri-demmaccs

The demmaccs service is cleaning the /mnt/archive/demmaccs_tmp folder after its execution so if you launch manual executions, is highly probable (as demmaccs is executed every minute) to delete also the temporary files of your manual execution. This was implemented as these temporary folders are usually quite big and in some cases (forced stop of maccs or stop due to insufficient disk space) they remained on disk, requiring manual deletion.
2. Use another existing directory in your command instead of --working-dir /mnt/archive/demmaccs_tmp/

Hope this helps.

Best regards,

1 Like

Thank you @cudroiu . I did follow the steps mentioned by you in the link below. Now the MAJA is working and L2A products are available. As I’m still on version 2.0, I’ll update regarding L8 products after I upgrade.